Uploaded image for project: 'ejabberd development'
  1. ejabberd development
  2. EJAB-1067

Empty username in exmpp_server_legacy_auth:fields

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Invalid
    • Affects Version/s: ejabberd 3.0.0-alpha-1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Looks like exmpp problem, not ejabberd, but it seems I cannot create tickets for exmpp project?

      Function fields/2 in exmpp/src/server/exmpp_server_legacy_auth.erl (r863) tries to get username from auth iq using the code

      Request_Username_El = exmpp_xml:get_element(Request_IQ, ?NS_LEGACY_AUTH, 'username')
      

      However, <username> is located several levels down in Request_IQ, and get_element is not recursive - so this code isn't likely to ever succeed.

      Therefore <auth> answer from ejabberd always contains empty <username> element regardless of what client sent in request.

      Changing exmpp_xml:get_element use to self-written recursive version fixes this.

        Activity

        badlop Badlop added a comment -

        it seems I cannot create tickets for exmpp project?

        Oh. The configuration has been changed. Try now to create a ticket in exmpp tracker.

        Looks like exmpp problem, not ejabberd

        Ok, in that case you can create a ticket in exmpp tracker, and later comment here the URL of the new ticket.

        badlop Badlop added a comment -

        What is the status of this ticket: did you report this to EXMPP? If so, can this ticket be closed?

        ndl Alexander Tsvyashchenko added a comment -

        I haven't tried to reproduce it in recent EXMPP versions and currently do not have time to do that, so for now I think it can be just dropped, hopefully I should be able to re-test it in a couple of months and then I will re-open it in EXMPP if it is still not solved.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development