Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: ejabberd 2.1.5
    • Fix Version/s: ejabberd 2.1.6
    • Component/s: Installer
    • Labels:
      None
    • Environment:
      Debian lenny (vServer) 2.6.33.2-vs2.3.0.36.30.4 32bit

      Description

      I've downloaded ejabberd .bin Installer from "http://www.process-one.net/downloads/ejabberd/2.1.5/ejabberd-2.1.5-linux-x86-installer.bin.gz"

      >> wget http://www.process-one.net/downloads/ejabberd/2.1.5/ejabberd-2.1.5-linux-x86-installer.bin.gz
      >> gunzip ejabberd-2.1.5-linux-x86-installer.bin.gz
      >> chmod a+x ejabberd-2.1.5-linux-x86-installer.bin.gz
      >> ./ejabberd-2.1.5-linux-x86-installer.bin.gz

      Now setting the required settings...

      >> Language: 2 (English)
      >> Install dir: /etc/ejabberd
      >> Host: webcf.de
      >> admin-name: robin
      >> pw: password (yes, simple password for testing )
      >> Cluster: No
      >> Continue?: Yes

      now the installer installs.... and while that i get this message:

      >> Installing
      >> 0% ______________ 50% ______________ 100%
      >> ########################################
      >> Error: Error running Post Install Script.
      >> The installation may have not completed correctly
      >> Press [Enter] to continue :

      Here the tailed install.log:

      [...]
      Unpacking /etc/ejabberd/doc/features.html
      Executing final installation script
      Error executing post installation script
      /etc/ejabberd/bin/postinstall.sh
      \child process exited abnormally
      Creating Uninstaller
      [...]

      Ok - see what ejabberd reports:

      #################################################
      =ERROR REPORT==== 2010-09-22 19:54:48 ===
      Error in process <0.99.0> on node 'ejabberd@localhost' with exit value: {{case_clause,{error,

      {open_error,-10}}},[{ejabberd_app,init,0}]}


      =INFO REPORT==== 2010-09-22 19:54:49 ===
      application: ejabberd
      exited: {bad_return,
      {{ejabberd_app,start,[normal,[]]},
      {'EXIT',
      {badarg,
      [{erlang,port_control,[stringprep_port,2,"webcf.de"]},
      {stringprep,control,2},
      {jlib,nodeprep,1},
      {ejabberd_config,normalize_hosts,2},
      {ejabberd_config,add_hosts_to_option,2},
      {lists,foldl,3},
      {ejabberd_config,load_file,1},
      {ejabberd_config,start,0}]}}}}
      type: temporary
      #################################################



      What say the erlang.log?



      #################################################
      =SUPERVISOR REPORT==== 22-Sep-2010::19:54:48 ===
      Supervisor: {local,stringprep_sup}
      Context: start_error
      Reason: {{case_clause,{error,{open_error,-10}

      }},
      [

      {stringprep,init,1}

      ,

      {gen_server,init_it,6}

      ,

      {proc_lib,init_p,5}

      ]}
      Offender: [

      {pid,undefined}

      ,

      {name,stringprep}

      ,
      {mfa,{stringprep,start_link,[]}},

      {restart_type,permanent}

      ,

      {shutdown,brutal_kill}

      ,

      {child_type,worker}

      ]

      #################################################

      So, i see that ejabberd is missing some stringprep.

      I've tried it several times, but i dont find any solution. I've tried 3.0.0a1, 2.1.5, 2.1.4 and 2.1.3 - nothing is working...

      A other vServer (other provider) works with ejabberd 2.1.5 but i dont know where the error could be...

      Still a bug?

        Activity

        Christophe Romain
        added a comment -

        odd, is that vserver using a special glibc ?
        what says ldd lib/ejabberd-2.1.5/priv/lib/linux-x86/stringprep_drv.so ?

        Show
        Christophe Romain
        added a comment - odd, is that vserver using a special glibc ? what says ldd lib/ejabberd-2.1.5/priv/lib/linux-x86/stringprep_drv.so ?
        Robin Kluth
        added a comment - - edited

        You have an error in your path but i found it anyway.

        s1:~# ldd /etc/ejabberd/lib/ejabberd-2.1.5/priv/linux-x86/lib/stringprep_drv.so
        linux-gate.so.1 => (0xf76fc000)
        libc.so.6 => /lib/libc.so.6 (0xf758d000)
        /lib/ld-linux.so.2 (0xf76fd000)

        EDIT: libc6/lenny uptodate 2.7-18lenny4

        Show
        Robin Kluth
        added a comment - - edited You have an error in your path but i found it anyway. s1:~# ldd /etc/ejabberd/lib/ejabberd-2.1.5/priv/linux-x86/lib/stringprep_drv.so linux-gate.so.1 => (0xf76fc000) libc.so.6 => /lib/libc.so.6 (0xf758d000) /lib/ld-linux.so.2 (0xf76fd000) EDIT: libc6/lenny uptodate 2.7-18lenny4
        Christophe Romain
        added a comment -

        what is the exact version of your installed libc6 ?

        Show
        Christophe Romain
        added a comment - what is the exact version of your installed libc6 ?
        Robin Kluth
        added a comment -

        See my post above:

        "libc6/lenny uptodate 2.7-18lenny4"

        Show
        Robin Kluth
        added a comment - See my post above: "libc6/lenny uptodate 2.7-18lenny4"
        Christophe Romain
        added a comment -

        2.1.6 installer will be checked against lenny binary stack

        Show
        Christophe Romain
        added a comment - 2.1.6 installer will be checked against lenny binary stack
        Robin Kluth
        added a comment - - edited

        Ok, thanks

        Show
        Robin Kluth
        added a comment - - edited Ok, thanks
        Christophe Romain
        added a comment -

        it's not a code issue, but a binary compatibility issue.
        so this will be fixed at compilation time, i'll take care of this.

        Show
        Christophe Romain
        added a comment - it's not a code issue, but a binary compatibility issue. so this will be fixed at compilation time, i'll take care of this.
        Robin Kluth
        added a comment - - edited

        Ok, the fix is included in 2.1.6, right? when will it release? or exists a way to fix the 2.1.5 binary installation way?

        Show
        Robin Kluth
        added a comment - - edited Ok, the fix is included in 2.1.6, right? when will it release? or exists a way to fix the 2.1.5 binary installation way?
        Christophe Romain
        added a comment -

        2.1.6 is not to be released yet
        if you want to fix your current installation, better to compile ejabberd
        from sources and copy generated .so in lib/ejabberd-2.1.5/priv/linux-x86/lib

        Show
        Christophe Romain
        added a comment - 2.1.6 is not to be released yet if you want to fix your current installation, better to compile ejabberd from sources and copy generated .so in lib/ejabberd-2.1.5/priv/linux-x86/lib
        Robin Kluth
        added a comment -

        Thank you! I'll try that!

        Show
        Robin Kluth
        added a comment - Thank you! I'll try that!
        Robin Kluth
        added a comment -

        I dont see the fix in git, yet. Is it already fixed an imported? Some idea when 2.1.6 could be released?

        Thanks!

        Show
        Robin Kluth
        added a comment - I dont see the fix in git, yet. Is it already fixed an imported? Some idea when 2.1.6 could be released? Thanks!
        Christophe Romain
        added a comment -

        there won't be any fix in git, this is a compilation environment issue.
        we're starting working on 2.1.6 release and it should be available by the end of next week

        Show
        Christophe Romain
        added a comment - there won't be any fix in git, this is a compilation environment issue. we're starting working on 2.1.6 release and it should be available by the end of next week
        Christophe Romain
        made changes -
        Field Original Value New Value
        Status Open [ 1 ] In Progress [ 3 ]
        Robin Kluth
        added a comment -

        So, i have to install all requirements and compile it manually, if i dont want to use the old version from the debian repository?

        Show
        Robin Kluth
        added a comment - So, i have to install all requirements and compile it manually, if i dont want to use the old version from the debian repository?
        Christophe Romain
        added a comment -

        indeed

        Show
        Christophe Romain
        added a comment - indeed
        Christophe Romain
        added a comment -

        issues does not come from compilation farm, i've tested the generated .so against lenny and it's ok.
        for the record, this is tested with up to date lenny (using libc6-2.7-18lenny6)

        i wonder if the vServer environment of that provider changes: maybe that's a custom patched libc6 (or something else at kernel level) that makes shared library incompatibilities...
        in any cases, i can not reproduce that issue on a standard lenny, and i don't see what we can do here.

        as said before, you can still compile ejabberd on that host to produce working .so

        Show
        Christophe Romain
        added a comment - issues does not come from compilation farm, i've tested the generated .so against lenny and it's ok. for the record, this is tested with up to date lenny (using libc6-2.7-18lenny6) i wonder if the vServer environment of that provider changes: maybe that's a custom patched libc6 (or something else at kernel level) that makes shared library incompatibilities... in any cases, i can not reproduce that issue on a standard lenny, and i don't see what we can do here. as said before, you can still compile ejabberd on that host to produce working .so
        Christophe Romain
        made changes -
        Status In Progress [ 3 ] Open [ 1 ]
        Christophe Romain
        added a comment -

        this is a specific issue related to that vServer environement.

        Show
        Christophe Romain
        added a comment - this is a specific issue related to that vServer environement.
        Christophe Romain
        made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Won't Fix [ 2 ]
        Mickaël Rémond
        made changes -
        Workflow development v3 [ 73141 ] Development v4 [ 81448 ]

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              3 years, 19 weeks, 5 days ago

              Issue deployment