Details

      Description

      Compilation of several C files with R15B shows warnings:

      expat_erl.c:252:4: warning: initialization from incompatible pointer type [enabled by default]
      expat_erl.c:252:4: warning: (near initialization for 'expat_driver_entry.control') [enabled by default]
      iconv_erl.c:145:4: warning: initialization from incompatible pointer type [enabled by default]
      iconv_erl.c:145:4: warning: (near initialization for 'iconv_driver_entry.control') [enabled by default]
      stringprep_drv.c:401:4: warning: initialization from incompatible pointer type [enabled by default]
      stringprep_drv.c:401:4: warning: (near initialization for 'stringprep_driver_entry.control') [enabled by default]
      tls_drv.c:504:4: warning: initialization from incompatible pointer type [enabled by default]
      tls_drv.c:504:4: warning: (near initialization for 'tls_driver_entry.control') [enabled by default]
      sha_drv.c:90:3: warning: initialization from incompatible pointer type [enabled by default]
      sha_drv.c:90:3: warning: (near initialization for 'sha_driver_entry.control') [enabled by default]
      ejabberd_zlib_drv.c:188:4: warning: initialization from incompatible pointer type [enabled by default]
      ejabberd_zlib_drv.c:188:4: warning: (near initialization for 'ejabberd_zlib_driver_entry.control') [enabled by default]
      

      And ejabberd initialization gets aborted due to problems to load some *.so files:

      =ERROR REPORT==== 16-Dec-2011::13:10:41 ===
      C(<0.39.0>:sha:53) : unable to load driver '/lib/ejabberd/priv/lib/sha_drv.so':
      Driver compiled with incorrect version of erl_driver.h
      ...
      

      Relevant links:

        Expenses

          Activity

          Hide
          badlop Badlop added a comment -

          Preliminary patch available. It works correctly with R15B, R14B04, and R13B04. Needs testing with versions from R10 up to R12.

          Show
          badlop Badlop added a comment - Preliminary patch available. It works correctly with R15B, R14B04, and R13B04. Needs testing with versions from R10 up to R12.

            People

            • Assignee:
              badlop Badlop
              Reporter:
              badlop Badlop
              Participants:
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development