Uploaded image for project: 'ejabberd development'
  1. ejabberd development
  2. EJAB-1683

shared roster groups error using odbc driver when manage

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: ejabberd 2.1.13, ejabberd 13.12, ejabberd 17.x
    • Fix Version/s: None
    • Component/s: Shared rosters
    • Environment:
      Debian squeeze, 4 cores Xeon, 16Gb ram, RAID1, redundant server.

      Description

      when i setup shared roster groups, and create one group, if edit to added user, get when finish "not found"

      I always had errors since version 2.1.11 to save the new feature in odbc groups have never seen it work with odbc database

      i follow:
      1) install ejabberd 2.1.13,13.XX or lasted binary with erlang specified by instaler
      2) test ejabbed install with nmesia db: all ok no error in debug log
      3) stop and setup postgresql database with pg.sql file, all access permited
      4) setup odbc to provide a DNS to ejabberd
      5) setup odbc in ejabberd and test acces: all ok
      6) setud and enable all modules, and roster and sahred roster to store in odbc with

      {db_type, odbc}

      option in this two modules
      7) start ejabberd and all start good, but when using shared roster group get this log:

      massenkoh:/var/log/ejabberd# tail ejabberd.log  -n 100
      
      =INFO REPORT==== 2014-02-13 10:51:44 ===
      I(<0.372.0>:ejabberd_listener:281) : (#Port<0.2935>) Accepted connection {{170,10,2,10},55099} -> {{170,10,2,11},5280}
      
      =INFO REPORT==== 2014-02-13 10:51:44 ===
      D(<0.384.0>:ejabberd_http:142) : S: [{["admin"],ejabberd_web_admin},
                                           {["http-bind"],mod_http_bind},
                                           {["http-poll"],ejabberd_http_poll}]
      
      
      =INFO REPORT==== 2014-02-13 10:51:44 ===
      I(<0.384.0>:ejabberd_http:146) : started: {tls,
                                                 {tlssock,#Port<0.2935>,
                                                  #Port<0.2940>}}
      
      =INFO REPORT==== 2014-02-13 10:51:44 ===
      I(<0.372.0>:ejabberd_listener:281) : (#Port<0.2941>) Accepted connection {{170,10,2,10},55101} -> {{170,10,2,11},5280}
      
      =INFO REPORT==== 2014-02-13 10:51:44 ===
      D(<0.385.0>:ejabberd_http:142) : S: [{["admin"],ejabberd_web_admin},
                                           {["http-bind"],mod_http_bind},
                                           {["http-poll"],ejabberd_http_poll}]
      
      
      =INFO REPORT==== 2014-02-13 10:51:44 ===
      I(<0.385.0>:ejabberd_http:146) : started: {tls,
                                                 {tlssock,#Port<0.2941>,
                                                  #Port<0.2942>}}
      
      =INFO REPORT==== 2014-02-13 10:51:44 ===
      D(<0.384.0>:ejabberd_http:966) : Method: "GET"
      
      
      =INFO REPORT==== 2014-02-13 10:51:44 ===
      D(<0.384.0>:ejabberd_http:973) : URI: "/admin/server/venenux.org/shared-roster/999-todos/"
      Version: "HTTP/1.1"
      L3: []
      
      
      =INFO REPORT==== 2014-02-13 10:51:44 ===
      D(<0.384.0>:ejabberd_http:268) : ({tlssock,#Port<0.2935>,#Port<0.2940>}) http query: 'GET' /admin/server/venenux.org/shared-roster/999-todos/
      
      
      =INFO REPORT==== 2014-02-13 10:51:44 ===
      D(<0.384.0>:ejabberd_http:346) : ["admin","server","venenux.org",
                                        "shared-roster","999-todos"] matches ["admin"]
      
      =ERROR REPORT==== 2014-02-13 10:51:44 ===
      E(<0.384.0>:ejabberd_hooks:335) : {{badmatch,
                                          {error,
                                           {1,erl_scan,
                                            {string,34,"999-todos\"},\n {d"}},
                                           1}},
                                         [{ejabberd_odbc,decode_term,1,
                                           [{file,"ejabberd_odbc.erl"},{line,178}]},
                                          {mod_shared_roster,shared_roster_group,4,
                                           [{file,"mod_shared_roster.erl"},
                                            {line,1109}]},
                                          {mod_shared_roster,webadmin_page,3,
                                           [{file,"mod_shared_roster.erl"},
                                            {line,1031}]},
                                          {ejabberd_hooks,run_fold1,4,
                                           [{file,"ejabberd_hooks.erl"},{line,331}]},
                                          {ejabberd_web_admin,process_admin,2,
                                           [{file,"ejabberd_web_admin.erl"},
                                            {line,1175}]},
                                          {ejabberd_http,process,2,
                                           [{file,"ejabberd_http.erl"},{line,352}]},
                                          {ejabberd_http,process_request,1,
                                           [{file,"ejabberd_http.erl"},{line,405}]},
                                          {ejabberd_http,process_header,2,
                                           [{file,"ejabberd_http.erl"},
                                            {line,278}]}]}
      running hook: {webadmin_page_host,
                        ["venenux.org",
                         {request,'GET',
                             ["shared-roster","999-todos"],
                             [{nokey,[]}],
                             {"lenz_mckay","venenux.org"},
                             {auth_jid,
                                 {"lenz_mckay","1234"},
                                 {jid,"lenz_mckay","venenux.org",[],
                                     "lenz_mckay","venenux.org",[]}},
                             "en-us",[],
                             {{170,10,2,10},55099},
                             "venenux.org",5280,https,
                             [{'Authorization',"Basic bGVuel9tY2theToxMjM0"},
                              {'Cookie',
                                  "language=es; TRACKID=dcb033f5cec0a74f4288df8353de7023; roundcube_sessid=csfd7i9q2sp7kgq5eomfqf2bu1; roundcube_sessauth=Sb0b47e18d5e78899320024ea277a6c03b683be4b"},
                              {'Referer',
                                  "https://venenux.org:5280/admin/server/venenux.org/shared-roster/"},
                              {'Connection',"keep-alive"},
                              {"Accept-Charset","ISO-8859-1,utf-8;q=0.7,*;q=0.7"},
                              {'Accept-Encoding',"gzip, deflate"},
                              {'Accept-Language',"en-us,en;q=0.5"},
                              {'Accept',
                                  "text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8"},
                              {'User-Agent',
                                  "Mozilla/5.0 (X11; Linux i686; rv:7.0.1) Gecko/20130330 iceweasel/7.0.1 IceCat/7.0.1"},
                              {'Host',"venenux.org:5280"}]}]}
      massenkoh:/var/log/ejabberd# 
      

        Activity

        mckaygerhard PICCORO Lenz McKAY added a comment -

        when i search in database the group are inserted, the problem its when edited to retrieve the details from database:

        999-todos	[{name,\"999-todos\"},\n {displayed_groups,[\"999-todos\"]},\n {all_users,true}]	2014-02-13 10:40:36.869009
        
        badlop Badlop added a comment -

        Using ejabberd 15.04 (source compiled) with Erlang R17B-3, odbc with MySQL database, I don't get that problem.

        Could it be related to PgSQL code in ejabberd? Did you try with recent ejabberd version? Did you use a recent PostgreSQL version?

        mckaygerhard PICCORO Lenz McKAY added a comment -

        recent version of postgresql but from stable branch.. not lasted (9.1.X)
        we no used any more ejabbed.. due does not support the stable environment of debian squeeze, we migrated to jabberd that are complety supported and are more flexyble related with older linux environment..

        badlop Badlop added a comment -

        Ok, then I'll close now as "Cannot reproduce".


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development