Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: ejabberd 2.0.2
    • Component/s: Installer
    • Labels:
      None

      Description

      The ejabberd binary installer, when Uninstalling, deletes everything except the directories database/ and logs/

      In particular, the directory conf/ is deleted, and all its files, even if the files were modified by the administrator.

      This directory should not be deleted. Or at least the modified or new files should be kept.

        Activity

        mremond@process-one.net Mickaël Rémond added a comment -

        To my knowledge the installer keeps all new and modified files during uninstall already (including /conf).

        cromain@process-one.net Christophe Romain added a comment -

        that's not what we see

        cromain@process-one.net Christophe Romain added a comment -

        i double checking the uninstall.
        indeed, created files are not removed.
        but modified files from conf are removed.
        I guess BitRock does not md5sum files at install/uninstall

        we have two solutions:
        1) Mickael sends the question to the support, and we may have a BitRock version that does not remove modified files
        2) I can use pre_uninstall.sh to do "mv conf conf.backup" before uninstall.

        I like 2 cause:

        • it's very quick to do
        • it allows to reinstall, having a fresh config with untouched database, and old config info conf.backup
        cromain@process-one.net Christophe Romain added a comment -

        i am OK for implementing pre_uninstall solution.
        we can even create conf.YYMMDD so we can keep history when installing/reinstalling several times

        badlop Badlop added a comment -

        Yes, good idea. Proposal:

        You implement 2) now, because it's a good idea.

        At the same time, Mickael asks Bitrock if there's an option to (or a plan to implement) protection of modified files during uninstallation.

        If someday BitRock is capable of protecting modified files during uninstallation, then you can improve 2) to backup only the modified files.

        mremond@process-one.net Mickaël Rémond added a comment -

        Actually, I described the existing behaviour: new and unmodified files
        are not deleted during uninstall.

        cromain@process-one.net Christophe Romain added a comment -

        hum ok i guess i found the problem.

        during uninstall:
        new files are not deleted
        all installed files from conf, modified or not, are deleted

        i guess the problem is that i install conf directory, without listing
        all files in it.
        indeed, files from bin directory are installed each having an entry
        in the bitrock's xml file.
        if i modifi ejabberdctl, then uninstall does not remove ejabberdctl;

        but conf (as config files may changes from a package to another, some
        uses hosts.cfg for example) is installed just as a directory, so
        bitrock knows only conf directory and not included files. so
        uninstall removes all conf directory.

        so this is not a bitrock issue. this is all about we install conf
        directory.
        i will not list all files installed in conf as i do not want one
        installer.xml per package.

        so i just implemented 2, and i guess it will say like this.

        cromain@process-one.net Christophe Romain added a comment -

        conf.DATE is created in preuninstall stage


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development