Uploaded image for project: 'ejabberd development'
  1. ejabberd development
  2. EJAB-738

Renaming contact from shared rosters sends push stanza with wrong name attribute

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: ejabberd 14.05
    • Component/s: Shared rosters
    • Labels:
      None
    • Environment:
      I observed this issue on process-one.net server

      Description

      Push stanza always contains name=<node part of contact's jid>, on connect stanza with correct name is sent through.

        Activity

        pchmielowski@process-one.net Pawel Chmielowski added a comment - - edited

        XML log from changing contact name to qqq:

        <iq type="set" id="509">
        <query xmlns="jabber:iq:roster">
        <item jid="aaa@bbb" name="qqq">
        <group>Tech</group>
        </item>
        </query>
        </iq>

        <iq from='me@bbb' to='me@bbb/Gajim' id='push' type='set'>
        <query xmlns='jabber:iq:roster'>
        <item subscription='both' name='aaa' jid='aaa@bbb'>
        <group>Tech</group>
        </item>
        </query>
        </iq>

        badlop Badlop added a comment -

        I think the problem is fixed in ejabberd trunk SVN r1764:

        1. Create two accounts in vhost 'localhost': test1 and test2.

        2. Create Shared Roster 'tt' with members test1@localhost and test2@localhost, and display 'tt'.

        3. Login to account test1@localhost/Home, then send:

        <iq type='set'>
          <query xmlns='jabber:iq:roster'>
            <item jid='test2@localhost'
        	name='Test 2'>
              <group>tt</group>
            </item>
          </query>
        </iq>
        

        4. The client receives the correct name:

        <iq from='test1@localhost'
        	id='push2626299649'
        	type='set'
        	to='test1@localhost/Home'>
          <query xmlns='jabber:iq:roster'>
            <item name='Test 2'
        	subscription='both'
        	jid='test2@localhost'>
              <group>tt</group>
            </item>
          </query>
        </iq>
        
        pchmielowski@process-one.net Pawel Chmielowski added a comment -

        Steps to reproduce wrong behavior from Mickael comment:
        1) Delete contact from shared roster which is currently available
        2) Shared roster manager re-adds this contact
        3) Rename contact
        4) Server sends push stanza with type=none (this is wrong)
        5) Server sends push stanza with type=both


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development