Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 1.5.1, 1.5.2
    • Fix Version/s: 1.5.2
    • Component/s: Core
    • Labels:
      None

      Description

      See more details, steps to reproduce and a patch https://github.com/processone/tsung/pull/102

      Here is the gist:

      During a load test with high arrival rates, I noticed a lot of collisions of generated random strings. The collision rate was quite reproducible at about 2%.

      The pull requests adds the tsung user id to the seed initialization used in ts_client:init/1.

      Additionally, providing a fixed seed via <option name="seed" value="4223"/> also causes collisions across clients. In fact the collision rate was significantly higher (see below).

      In my opinion both issues are severe, since you have to rely on the fact, that the randomness is strong enough. Collisions rates

      The following configuration can be used to reproduce the issue and validate the changes. Using this configuration, you'll see collision rates up to 7% (against https://github.com/processone/tsung/tree/924b5170533a09e7f404b3875b85129104e9312b)

        Activity

        nniclausse Nicolas Niclausse added a comment -

        PR#102 merged, thanks.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development